Back to overview
Resolved
High load
Jul 1, 2026 at 7:01pm UTC
Affected services
Spiich Web App
Background Agents
Resolved
Jul 1, 2026 at 9:02pm UTC
We have found the cause and solved the issue
Affected services
Created
Jul 1, 2026 at 7:01pm UTC
Unexpectedly high load times due to unexpected amount of usage
Affected services